Welcome to the Tormek Community. If you previously registered for the discussion board but had not made any posts, your membership may have been purged. Secure your membership in this community by joining in the conversations.

Main Menu

Won't turn on

Started by adamleewy, December 03, 2019, 05:56:31 AM

Previous topic - Next topic


I spent about 2-3 hours truing and then sharpening a few chisels and a plane iron. At one point it just won't turn on. I switched outlets, and it came back on. I went on truing, and I hadn't tightened down the jig because it came loose and my wheel came to a complete stop/shut down. After cursing myself and properly setting up, I started it again, continuing to flatten the stone. After switching it off a few minutes later, it again wouldn't start. I've tried again intermittently for the last five hours with no success. I have certainly used it for longer and worked it harder than I did today. Any ideas on what could be wrong and what I should do?
I have the T4. I've used it maybe 8 times in the two years I've had it, usually about 2 hours each time
I've used it the better part of an afternoon before though. Always dried, cleaned, stored indoors.
Thank you

Ken S

This is definitely an issue for support. ( Please contact them
Also, please keep us posted with the resolution.


I emailed them, I'll post the response here.
Thank you.